Most Axelerant Plugins Require PHP 5.3 +

I'm very sorry for the troubles you've just encountered. You're probably here because, you just found out you're running PHP 5.2.

My webhost says I'm running PHP 5.3, 5.4, or 5.5…

More than likely though, it's available to you, but you're not running it yet.

If you're seeing an error message like the following, then you're running PHP 5.2 or lower.

Parse error: syntax error, unexpected T_STATIC, expecting ')' in ...\wp-content\plugins\custom-bulkquick-edit\lib\aihrus\class-aihrus-common.php on line 44

If you don't believe it, then create a `phpinfo.php` file in your website root with the code below. Then using your web browser, call it via `` to see which PHP version you're running.

<?php phpinfo(); ?> 

Now, see the DIY section below for solutions.

Plugins Affected

  • Testimonials 2.16.0+
  • Testimonials Premium 1.17.0+
  • Custom Bulk/Quick Edit 1.3.0+
  • Custom Bulk/Quick Edit Premium 1.3.0+
  • GC Testimonials to Testimonials 1.0.0+

DIY – Fix The Problem

Which PHP Version?

PHP 5.3+ means PHP 5.3 or newer is required. So PHP 5.3, 5.4, or 5.5 should be fine. Truthfully, you should use PHP 5.5 so that you don't have to worry about this for a few more years again.

.htaccess Edit

On many web hosts, just add the following code to the top of your `.htaccess` file in your website root directory.

AddType application/x-httpd-php53 .php

Or try

AddHandler application/x-httpd-php53 .php .php5 .php4 .php3


  1. Log into your control panel
  2. Select CGI and Scripted Language Support
  3. Select PHP Scripting
  4. In the Select Default PHP Version section, select version 5.3 or newer

Thank you Ascii King for cPanel guidance.

Delete via FTP

You can delete the offending plugin via FTP, get back into WordPress, and then upload one of the older Testimonials versions like that's available from

Update Your PHP Version

Some web hosts allow you to change your PHP version. The links below should help you do so.

If your web host doesn't allow you to change the PHP version, email their support department to request a current version of PHP.

Why PHP 5.3 or newer?

Axelerant is moving forward in developing using current technology and techniques. As such, at some points in time during software development a crossed bridge must be burned. So that we can use things like…

After Updating, Clear Your Caches!

Still No Go…

The condition you mention is rare, but does happen when the server's main PHP version isn't PHP 5.3+ and the PHP 5.3+ configuration is via .htaccess or the like. A server change so that it's providing PHP 5.3+ by default will resolve things.

Wasn't Testing Done?


These plugins go out to 30+ beta testers, several live and development sites, a multitude of tests are run, and coding standards are met before any release happens. Frankly, software releases are a major pain because of so much hassle in getting good enough testing completed.

More beta testers are always welcome. You get free licensing and support for the products you provide feedback upon.

WordPress Stats

See them.

I Can't Upgrade to PHP 5.3+

Then download and use the last PHP 5.2 compatible version.